Foros Club Delphi

Foros Club Delphi (http://www.clubdelphi.com/foros/index.php)
-   Conexión con bases de datos (http://www.clubdelphi.com/foros/forumdisplay.php?f=2)
-   -   Conectar firebird 3.0 y ado.net (http://www.clubdelphi.com/foros/showthread.php?t=92256)

ronimaxh 08-09-2017 17:49:20

Conectar firebird 3.0 y ado.net
 
Hola amigos del club quiero pedirles una ayuda, estoy haciendo el proceso de migración de firebird 2.5 a firebird 3.0 luego de instalar firebird 3.0, realicé una prueba de conexion desde mi aplicacion en C#, usando FirebirdSql.Data.FirebirdClient-5.11.0.0-NET45.7 me da un error el tipo de error en este ejemplo:

Código Delphi [-]
 string cadena = @"User = SYSDBA; Password = masterkey; Database = C:\prueba\P.FDB; Datasource = localhost; Port = 3050; Dialect = 3";
            FbConnection conn = new FbConnection(cadena);

            try
            {
                conn.Open();
                MessageBox.Show("Conexion exitosa", "Atencion", MessageBoxButtons.OK, MessageBoxIcon.Information);
                conn.Close();
            }
            catch (Exception ex)
            {
                conn.Close();
                MessageBox.Show("Error al interner abrir la conexion ( "+ex.Message+" )", "Atencion", MessageBoxButtons.OK, MessageBoxIcon.Information);
            }

//error "Incompatible wire encryption levels requested on client and server"

ronimaxh 22-09-2017 17:22:04

Hola amigos encontré esta información en Internet:

Por defecto, Firebird 3 requiere encriptación, pero como esto no es compatible con la versión 5 del proveedor de Firebird .NET, se obtiene el error "Incompatible wire encryption levels required en cliente y servidor".


Nota
: favor de informar a los colaboradores que le dan soporte al Proveedor .NET en https://www.firebirdsql.org. Les agradezco su ayuda.

Casimiro Notevi 22-09-2017 21:28:35

https://stackoverflow.com/questions/...ebird#37497020
http://octuplus.co/Detalles/9456/Err...lient-and-serv

ronimaxh 24-09-2017 19:29:58

Gracias casimiro vi ese link lo probé y no funcionó.

Casimiro Notevi 24-09-2017 20:41:59

Has probado los 2 links y ninguno funciona, y el problema, error, motivo de que no funcione es... ¿?

ronimaxh 25-09-2017 00:25:38

Hola, cambié el archivo (firebird.conf) en esta parte WireCrypt = Enabledel
y me sigue dando el mismo error del principio:

Código:

//error "Incompatible wire encryption levels requested on client and server"

Casimiro Notevi 25-09-2017 00:52:18

Cita:

Empezado por ronimaxh (Mensaje 521279)
Hola, cambié el archivo (firebird.conf) en esta parte WireCrypt = Enabledel

Es enabled.

ronimaxh 26-09-2017 20:50:49

Si copie mal gracias.


La franja horaria es GMT +2. Ahora son las 18:10:14.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi