Foros Club Delphi

Foros Club Delphi (http://www.clubdelphi.com/foros/index.php)
-   PostgreSQL (http://www.clubdelphi.com/foros/forumdisplay.php?f=42)
-   -   postgres, zeoslib y dbgrid (http://www.clubdelphi.com/foros/showthread.php?t=17156)

unreal4u 26-12-2004 23:55:03

postgres, zeoslib y dbgrid
 
wolas a toda la comunidad ...

tengo un pequeño problema, estoy usando el zeoslib para conectarme a una base de datos postgres. Con la conexión, ni un problema, en tiempo de diseño me muestra los datos; pero al hacer una consulta SQL (tipo SELECT apellido from usuarios), no me actualiza la vista en el DBGrid, y se queda allí mismo ... la verdad es que anteriormente al editar o hacer algo parecido, le ponía Table1.refresh y listo; sólo que ahora no me funciona.

Ahora bien, con la consulta tampoco hay drama alguno, pues manda un mensaje de error en el caso de que la sentencia SQL esté mal escrito; o sea, la consulta la hace; sin embargo, no me actualiza la vista...

Esperando respuesta, desde ya muchas gracias: Camilo Sperberg.-

Gydba 28-12-2004 14:02:56

Hola,

Qué versión de Dehlpi y Zeos utilizás? Se queda colgado cuando enlazas el datasource al DBGrid?

unreal4u 29-12-2004 16:55:34

ocupo delphi 6 y zeoslib 6.1.5 (no me acuerdo bien de la versión en este momento, pero es la última. Respecto a la otra duda, no tengo ningún problema; no se queda colgado ni nada.

En todo caso, después de 3 ó 4 días de intensos dolores de cabeza (recién ayer en la noche lo solucioné) ahora estoy metido en otro problema, pero eso debería ir en el foro SQL, así que allí lo voy a publicar.

En todo caso, muchas gracias por responder ... Cualquier aporte a ayudar a manejar zeoslib lo agradecería mucho...

Ahora q lo pensé mejor, en realidad tengo una duda: el charset que maneja Windows... cuàl es? Y en delphi, para cambiar el charset... cómo se hace? Es que tengo un montón de problemas con las tildes, y me salen unas letras q nada q ver con lo q quisiera ver ...

eso sería todo, muchas gracias...

Casimiro Notevi 02-06-2017 18:58:48

Cita:

Empezado por brincola (Mensaje 517573)
¿Cómo enlazar/(acceder a) un array de datos de una tabla Posgre en una consulta desde Delphi (7 o también XE10 Seattle)?
Gracias.

Creo un hilo nuevo con tu duda.
No olvides nuestra guía de estilo, gracias.

brincola 02-06-2017 19:12:30

Aún no estoy muy ducho con la operativa en esta WEB. Pido disculpas por los errores (pasados y futuros).

Casimiro Notevi 02-06-2017 19:28:28

No te preocupes, es comprensible ^\||/


La franja horaria es GMT +2. Ahora son las 20:13:31.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi