Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Internet
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #2861  
Antiguo 11-06-2018
lithium76 lithium76 is offline
Miembro
 
Registrado: Jan 2015
Posts: 25
Poder: 0
lithium76 Va por buen camino
Talking Muchas gracias por los WSDL

Buenas,

Muchísimas gracias a [newtron] y pablog2k. Me habéis salvado la vida. Así da gusto. A ver si algún dia puedo hacer yo un aporte así en este hilo. Aunque lo veo difícil que hay mucho crack suelto por aquí
Responder Con Cita
  #2862  
Antiguo 12-06-2018
elcharlie elcharlie is offline
Miembro
 
Registrado: Mar 2013
Posts: 43
Poder: 0
elcharlie Va por buen camino
Hola chic@s, estoy haciendo las pruebas de envío con la versión 1.1, y en Navarra y Alava no me va.
¿Alguien ha probado a enviar algún dato a los servidores de Navarra o Alava?

Es que ya no sé si tengo mal las Urls o no están habilitados los servidores de pruebas,......
Tampoco documentan nada,....
Responder Con Cita
  #2863  
Antiguo 12-06-2018
Avatar de keys
keys keys is offline
Miembro
 
Registrado: Sep 2003
Ubicación: Bilbao
Posts: 394
Poder: 16
keys Va por buen camino
Alava no ha empezado. Las cosas de palacio van despacio.
Navarra si, ya que van con la aeat.

https://siihacienda.navarra.es/SII_P...sdHandlet.ashx

Última edición por keys fecha: 12-06-2018 a las 08:25:01.
Responder Con Cita
  #2864  
Antiguo 12-06-2018
Avatar de keys
keys keys is offline
Miembro
 
Registrado: Sep 2003
Ubicación: Bilbao
Posts: 394
Poder: 16
keys Va por buen camino
Perdón me contesto y me fustigo. Alava si ha empezado el periodo de pruebas.
Responder Con Cita
  #2865  
Antiguo 12-06-2018
elcharlie elcharlie is offline
Miembro
 
Registrado: Mar 2013
Posts: 43
Poder: 0
elcharlie Va por buen camino
Cita:
Empezado por keys Ver Mensaje
Alava no ha empezado. Las cosas de palacio van despacio.
Navarra si, ya que van con la aeat.

https://siihacienda.navarra.es/SII_P...sdHandlet.ashx

Gracias, pero el de navarra me sigue sin ir, bueno me sigue sin ir ninguno de los dos.
Estas son las constantes que tengo para Suministro de Facturas Emitidas:

FE_defWSDL_Pruebas_Nafarroa = 'ht..s://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroFactEmitidas.wsdl';
FE_defURL_Pruebas_Nafarroa = 'ht..s://sii_hacienda.navarra.es/SII_PRUEBAS.proxy/SiiMensajesXsdHandlet.ashx';
FE_defSvc_Pruebas_Nafarroa = 'siiService';
FE_defPrt_Pruebas_Nafarroa = 'SuministroFactEmitidasPruebas';


y estas, las de Alava:

FE_defWSDL_Pruebas_Araba = 'ht..s://sii.araba.eus/documentos/SuministroFactEmitidas.wsdl';
FE_defURL_Pruebas_Araba = 'ht..s://pruebas-sii.araba.eus/SSII-FACT/ws/fe/SiiFactFEV1SOAP';
FE_defSvc_Pruebas_Araba = 'siiService';
FE_defPrt_Pruebas_Araba = 'SuministroFactEmitidas';

Yo creo que son las correctas, pero ya no sé.

Última edición por elcharlie fecha: 12-06-2018 a las 08:59:38.
Responder Con Cita
  #2866  
Antiguo 12-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Hola a todos,

Estoy empezando a hacer pruebas con la versión 1.1 y me sucede algo curioso. Al hacer el envío de una factura emitida me salta la siguiente excepción: Invalid property element: 1.1

Pero lo curioso es que consulto el portal y la factura se ha enviado correctamente. También proceso el xml generado mediante la utilidad de la AEAT y me la da por buena. Entonces, llego a la conclusión de que es el componente HTTPRIO que no tiene bien configurada alguna propiedad. Lo raro es que lo tengo exactamente igual que en la versión 1.0 y con esa me funciona correctamente.

También leí en el hilo, que en el componente HTTPRIO había que marcar las propiedades Converter --> Options --> soDocument y soLiteralParams a True, pero tampoco me funciona.

Alguna idea? Muchas gracias!
Responder Con Cita
  #2867  
Antiguo 12-06-2018
elcharlie elcharlie is offline
Miembro
 
Registrado: Mar 2013
Posts: 43
Poder: 0
elcharlie Va por buen camino
Cita:
Empezado por APO Ver Mensaje
Hola a todos,

Estoy empezando a hacer pruebas con la versión 1.1 y me sucede algo curioso. Al hacer el envío de una factura emitida me salta la siguiente excepción: Invalid property element: 1.1

Pero lo curioso es que consulto el portal y la factura se ha enviado correctamente. También proceso el xml generado mediante la utilidad de la AEAT y me la da por buena. Entonces, llego a la conclusión de que es el componente HTTPRIO que no tiene bien configurada alguna propiedad. Lo raro es que lo tengo exactamente igual que en la versión 1.0 y con esa me funciona correctamente.

También leí en el hilo, que en el componente HTTPRIO había que marcar las propiedades Converter --> Options --> soDocument y soLiteralParams a True, pero tampoco me funciona.

Alguna idea? Muchas gracias!
Eso te dice cuando lo intentas enviar al servidor de 1.0, lo tienes que enviar al de la 1.1
Esta es la url de Suministros de facturas emitidas de pruebas de la 1.1:

ht..s://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroFactEmitidas.wsdl

Última edición por elcharlie fecha: 12-06-2018 a las 11:29:02.
Responder Con Cita
  #2868  
Antiguo 12-06-2018
Virman Virman is offline
Miembro
 
Registrado: Jan 2017
Posts: 60
Poder: 2
Virman Va por buen camino
SII Canarias a partir del 1 de Enero de 2019

He visto que a partir del 1 de Enero de 2019 se va a implantar el SII en Canarias. En la página de la AEAT no logro encontrar nada a los esquemas que va a utilizar ni los webservices, etc.

Alguien tiene conocimiento de ello? Alguna información o link de referencia?

Muchas gracias.

Un saludo.
Responder Con Cita
  #2869  
Antiguo 12-06-2018
Virman Virman is offline
Miembro
 
Registrado: Jan 2017
Posts: 60
Poder: 2
Virman Va por buen camino
Modificar Facturas con Fecha Expedición Incorrecta

Buenos días,
Una empresa nos ha informado que ha enviado facturas recibidas con fecha expedición incorrecta. Para estas facturas, se podría enviar un xml de modificación, entiendo que no, al tratarse de un campo clave.

Las facturas rectificativas de sustitución entiendo que es para cambiar bases imponibles y cuotas, pero no para cambiar la fecha de expedición de una factura.

La única manera que se me ocurre es enviar una solicitud para anular todas las facturas incorrectas y volver a enviarlas con la fecha corregida.

Habría otra solución o sólo me queda enviar la solicitud de anulación de las facturas con problemas y volver a enviarlas con la fecha expedición corregida?

Mucha gracias por vuestra ayuda.
Responder Con Cita
  #2870  
Antiguo 12-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Cita:
Hola a todos,

Estoy empezando a hacer pruebas con la versión 1.1 y me sucede algo curioso. Al hacer el envío de una factura emitida me salta la siguiente excepción: Invalid property element: 1.1

Pero lo curioso es que consulto el portal y la factura se ha enviado correctamente. También proceso el xml generado mediante la utilidad de la AEAT y me la da por buena. Entonces, llego a la conclusión de que es el componente HTTPRIO que no tiene bien configurada alguna propiedad. Lo raro es que lo tengo exactamente igual que en la versión 1.0 y con esa me funciona correctamente.

También leí en el hilo, que en el componente HTTPRIO había que marcar las propiedades Converter --> Options --> soDocument y soLiteralParams a True, pero tampoco me funciona.

Alguna idea? Muchas gracias!
Cita:
Empezado por elcharlie Ver Mensaje
Eso te dice cuando lo intentas enviar al servidor de 1.0, lo tienes que enviar al de la 1.1
Esta es la url de Suministros de facturas emitidas de pruebas de la 1.1:

ht..s://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroFactEmitidas.wsdl
He verificado la url y la estoy enviando al servidor de pruebas 1.1

ht..s://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroFactEmitidas.wsdl

Con el puerto

SuministroFactEmitidasPruebas
Responder Con Cita
  #2871  
Antiguo 12-06-2018
pablog2k pablog2k is offline
Miembro
 
Registrado: May 2017
Posts: 19
Poder: 0
pablog2k Va por buen camino
Cita:
Empezado por APO Ver Mensaje
He verificado la url y la estoy enviando al servidor de pruebas 1.1

ht..s://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroFactEmitidas.wsdl

Con el puerto

SuministroFactEmitidasPruebas
los xml generados, cuando envías facturas con version 1.0 y con version 1.1, son iguales pero solo cambia la versión? ya que el servidor de pruebas no ha cambiado y es el mismo
Responder Con Cita
  #2872  
Antiguo 12-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Cita:
Empezado por pablog2k Ver Mensaje
los xml generados, cuando envías facturas con version 1.0 y con version 1.1, son iguales pero solo cambia la versión? ya que el servidor de pruebas no ha cambiado y es el mismo
Sí, de hecho, cuando comparo los dos xml son exactamente iguales excepto las siguientes etiquetas:

<IDVersionSii>1.0</IDVersionSii> --> <IDVersionSii>1.1</IDVersionSii>

En estos casos sólo cambian los nombres de las etiquetas:

<PeriodoImpositivo> --> <PeriodoLiquidacion>
<EmitidaPorTerceros> --> <EmitidaPorTercerosODestinatario>
Responder Con Cita
  #2873  
Antiguo 12-06-2018
pablog2k pablog2k is offline
Miembro
 
Registrado: May 2017
Posts: 19
Poder: 0
pablog2k Va por buen camino
Cita:
Empezado por APO Ver Mensaje
Sí, de hecho, cuando comparo los dos xml son exactamente iguales excepto las siguientes etiquetas:

<IDVersionSii>1.0</IDVersionSii> --> <IDVersionSii>1.1</IDVersionSii>

En estos casos sólo cambian los nombres de las etiquetas:

<PeriodoImpositivo> --> <PeriodoLiquidacion>
<EmitidaPorTerceros> --> <EmitidaPorTercerosODestinatario>
pues no se me ocurre que puede ser, yo acabo de hacer una prueba de envío con la versión 1.1 y me ha funcionado
Responder Con Cita
  #2874  
Antiguo 13-06-2018
Avatar de keys
keys keys is offline
Miembro
 
Registrado: Sep 2003
Ubicación: Bilbao
Posts: 394
Poder: 16
keys Va por buen camino
Cita:
Empezado por APO Ver Mensaje
Sí, de hecho, cuando comparo los dos xml son exactamente iguales excepto las siguientes etiquetas:

<IDVersionSii>1.0</IDVersionSii> --> <IDVersionSii>1.1</IDVersionSii>

En estos casos sólo cambian los nombres de las etiquetas:

<PeriodoImpositivo> --> <PeriodoLiquidacion>
<EmitidaPorTerceros> --> <EmitidaPorTercerosODestinatario>
¿Has probado hacer la prueba a través del cliente web service del portal de pruebas de la aeat?.
https://www7.aeat.es/PRE-Exteriores/...formacion.html
Responder Con Cita
  #2875  
Antiguo 13-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Cita:
Empezado por pablog2k Ver Mensaje
pues no se me ocurre que puede ser, yo acabo de hacer una prueba de envío con la versión 1.1 y me ha funcionado
Vaya, pues no lo entiendo. Utilizas también el objeto HTTPRIO? Si es así, qué opciones tienes marcadas?

Ah, otra cosa curiosa que he visto en el xml generado, es el Namespace que me pone por defecto. Parece como si estuviera apuntando a la versión antigua. Me pone lo siguiente:

<SuministroLRFacturasEmitidas xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroLR.xsd">

En vez de sii no debería poner ssii_1_1?

<SuministroLRFacturasEmitidas xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroLR.xsd">

Si pudierais verificar que pone en vuestros xml, Gracias!!
Responder Con Cita
  #2876  
Antiguo 13-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Cita:
Empezado por keys Ver Mensaje
¿Has probado hacer la prueba a través del cliente web service del portal de pruebas de la aeat?.
https://www7.aeat.es/PRE-Exteriores/...formacion.html
Sí, a través del portal me acepta el xml sin problemas. Es cuando lo hago a través de Delphi que al hacer el GetsiiSOAP(True,'',HTTPRIO_Emitidas)... me salta la excepción. Aunque lo bueno es que lo envía porque después consulto las facturas y están.
Responder Con Cita
  #2877  
Antiguo 13-06-2018
Avatar de newtron
[newtron] newtron is offline
Membrillo Premium
 
Registrado: Apr 2007
Ubicación: Motril, Granada
Posts: 2.983
Poder: 14
newtron Va camino a la fama
Cita:
Empezado por Virman Ver Mensaje
Buenos días,
Una empresa nos ha informado que ha enviado facturas recibidas con fecha expedición incorrecta. Para estas facturas, se podría enviar un xml de modificación, entiendo que no, al tratarse de un campo clave.

Las facturas rectificativas de sustitución entiendo que es para cambiar bases imponibles y cuotas, pero no para cambiar la fecha de expedición de una factura.

La única manera que se me ocurre es enviar una solicitud para anular todas las facturas incorrectas y volver a enviarlas con la fecha corregida.

Habría otra solución o sólo me queda enviar la solicitud de anulación de las facturas con problemas y volver a enviarlas con la fecha expedición corregida?

Mucha gracias por vuestra ayuda.

Que yo sepa la fecha no se puede modificar así que lo único que te queda es anular la factura y reenviarla, lo que no sé es si podrás enviarla de nuevo con el mismo número de factura, en el caso de las emitidas no lo permite tampoco.


Saludos
__________________
Be water my friend.
Responder Con Cita
  #2878  
Antiguo 13-06-2018
pablog2k pablog2k is offline
Miembro
 
Registrado: May 2017
Posts: 19
Poder: 0
pablog2k Va por buen camino
Cita:
Empezado por APO Ver Mensaje
Vaya, pues no lo entiendo. Utilizas también el objeto HTTPRIO? Si es así, qué opciones tienes marcadas?

Ah, otra cosa curiosa que he visto en el xml generado, es el Namespace que me pone por defecto. Parece como si estuviera apuntando a la versión antigua. Me pone lo siguiente:

<SuministroLRFacturasEmitidas xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroLR.xsd">

En vez de sii no debería poner ssii_1_1?

<SuministroLRFacturasEmitidas xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii_1_1/fact/ws/SuministroLR.xsd">

Si pudierais verificar que pone en vuestros xml, Gracias!!
los namespace los genera asi : = https://www2.agenciatributaria.gob.e...nformacion.xsd


te hago un copy paste del xml generado y enviado OK con la version 1.1 (tapando datos)
Código:
<?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
	<SOAP-ENV:Body>
		<SuministroLRFacturasEmitidas xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroLR.xsd">
			<Cabecera xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">
				<IDVersionSii>1.1</IDVersionSii>
				<Titular>
					<NombreRazon>XXXXXXX</NombreRazon>
					<NIFRepresentante>XXXXXXX</NIFRepresentante>
					<NIF>XXXXXX</NIF>
				</Titular>
				<TipoComunicacion>A0</TipoComunicacion>
			</Cabecera>
			<RegistroLRFacturasEmitidas>
				<PeriodoLiquidacion xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">
					<Ejercicio>2018</Ejercicio>
					<Periodo>2T</Periodo>
				</PeriodoLiquidacion>
				<IDFactura>
					<IDEmisorFactura xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">
						<NIF>XXXXXXX</NIF>
					</IDEmisorFactura>
					<NumSerieFacturaEmisor xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">A112</NumSerieFacturaEmisor>
					<NumSerieFacturaEmisorResumenFin xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd"/>
					<FechaExpedicionFacturaEmisor xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">08-06-2018</FechaExpedicionFacturaEmisor>
				</IDFactura>
				<FacturaExpedida>
					<TipoFactura xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">F1</TipoFactura>
					<ClaveRegimenEspecialOTrascendencia xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">07</ClaveRegimenEspecialOTrascendencia>
					<NumRegistroAcuerdoFacturacion xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd"/>
					<ImporteTotal xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">326.70</ImporteTotal>
					<BaseImponibleACoste xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd"/>
					<DescripcionOperacion xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">PROCESADOR UNIVERSAL</DescripcionOperacion>
					<RefExterna xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">21190</RefExterna>
					<ImporteTransmisionInmueblesSujetoAIVA xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd"/>
					<EmitidaPorTercerosODestinatario xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">N</EmitidaPorTercerosODestinatario>
					<VariosDestinatarios xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">N</VariosDestinatarios>
					<Contraparte xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">
						<NombreRazon>XXXXXXXXX</NombreRazon>
						<NIFRepresentante/>
						<NIF>XXXXXXXX</NIF>
					</Contraparte>
					<TipoDesglose xmlns="https://www2.agenciatributaria.gob.es/static_files/common/internet/dep/aplicaciones/es/aeat/ssii/fact/ws/SuministroInformacion.xsd">
						<DesgloseTipoOperacion>
							<Entrega>
								<Sujeta>
									<NoExenta>
										<TipoNoExenta>S1</TipoNoExenta>
										<DesgloseIVA>
											<DetalleIVA>
												<TipoImpositivo>21</TipoImpositivo>
												<BaseImponible>270</BaseImponible>
												<CuotaRepercutida>56.7</CuotaRepercutida>
												<TipoRecargoEquivalencia/>
												<CuotaRecargoEquivalencia/>
											</DetalleIVA>
										</DesgloseIVA>
									</NoExenta>
								</Sujeta>
							</Entrega>
						</DesgloseTipoOperacion>
					</TipoDesglose>
				</FacturaExpedida>
			</RegistroLRFacturasEmitidas>
		</SuministroLRFacturasEmitidas>
	</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
Responder Con Cita
  #2879  
Antiguo 13-06-2018
APO APO is offline
Miembro
 
Registrado: Feb 2008
Posts: 57
Poder: 11
APO Va por buen camino
Cita:
Empezado por APO Ver Mensaje
Hola a todos,

Estoy empezando a hacer pruebas con la versión 1.1 y me sucede algo curioso. Al hacer el envío de una factura emitida me salta la siguiente excepción: Invalid property element: 1.1

Pero lo curioso es que consulto el portal y la factura se ha enviado correctamente. También proceso el xml generado mediante la utilidad de la AEAT y me la da por buena. Entonces, llego a la conclusión de que es el componente HTTPRIO que no tiene bien configurada alguna propiedad. Lo raro es que lo tengo exactamente igual que en la versión 1.0 y con esa me funciona correctamente.

También leí en el hilo, que en el componente HTTPRIO había que marcar las propiedades Converter --> Options --> soDocument y soLiteralParams a True, pero tampoco me funciona.

Alguna idea? Muchas gracias!
Muchas gracias por vuestra ayuda y aportaciones. Finalmente ya he dado con la solución gracias a otro forero que le pasaba lo mismo.

El tema está, en que si en el proyecto Delphi se hace referencia a las dos versiones la 1.0 y la 1.1, si se envía al SII con la versión 1.1 da el error Invalid property element. En cambio, si en el proyecto se quita todo lo que haga referencia a la versión 1.0 entonces sí que funciona correctamente (un poco alucinante).

Entonces, una solución rápida para salir del paso es generar dos ejecutables distintos. Para distinguirlos se pueden generar utilizando directivas de compilación, algo del estilo (en el dproj):

Código Delphi [-]
{$ifdef SII_CURRENT_VERSION}
    SuministroFactEmitidas11 in 'SII\1.1\SuministroFactEmitidas11.pas',
    SuministroFactRecibidas11 in 'SII\1.1\SuministroFactRecibidas11.pas',
    SuministroOpTrascendTribu11 in 'SII\1.1\SuministroOpTrascendTribu11.pas',
    
    otros ficheros *.pas que trabajan con la 1.1

  {$else}
    SuministroFactEmitidas10 in 'SII\1.0\SuministroFactEmitidas10.pas',
    SuministroFactRecibidas10 in 'SII\1.0\SuministroFactRecibidas10.pas',
    SuministroOpTrascendTribu10 in 'SII\1.0\SuministroOpTrascendTribu10.pas',
     
    otros ficheros *.pas que trabajan con la 1.0
   
  {$endif SII_CURRENT_VERSION}
Responder Con Cita
  #2880  
Antiguo 14-06-2018
nuevo1234 nuevo1234 is offline
Miembro
 
Registrado: Apr 2017
Posts: 68
Poder: 2
nuevo1234 Va por buen camino
[quote=newtron;527080]Que yo sepa la fecha no se puede modificar así que lo único que te queda es anular la factura y reenviarla, lo que no sé es si podrás enviarla de nuevo con el mismo número de factura, en el caso de las emitidas no lo permite tampoco.


Saludos[/QUOTE

Si cambias fecha sí puedes repetir número de serie
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Error en Webservice funcion envio de sms webmasterplc Delphi para la web 5 25-07-2013 20:10:29
Problemas con envío de XML a un WebService davidvamo Internet 1 13-02-2007 15:49:20
Aplicacion Agencia De Viajes ArdiIIa Varios 9 20-01-2007 16:49:53
Nuevo en WebService CARSOFT_AR Internet 0 27-06-2006 20:00:56
Yahoo lanzará nuevo servicio que facilita envío fotos en la web marcoszorrilla Noticias 0 26-05-2005 15:37:47


La franja horaria es GMT +2. Ahora son las 02:14:01.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi