Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Internet
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 13-12-2009
camino camino is offline
Miembro
 
Registrado: Feb 2007
Posts: 45
Poder: 0
camino Va por buen camino
Enviar Email con Indy 10 y GMail ssl

Buenas tardes amigos.
Tengo Delphi7 e Indy 10

Recorriendo los hilos me encontre con una buena solucion para enviar e_Mails con una cuenta GMail.

Uso las Dlls "Libeay32.dll" y "ssleay32.dll" y todo funciona perfectamente salvo por lo siguiente:

Cuando ejecuto por primera vez la aplicacion da un mensaje de error "could not load ssl library".

Pero estando abierta la aplicacion todos los siguientes E_Mails son enviados sin problemas.

Viendo esto pense que la primera vez no cargaba las dlls (obvio) asi que
modifique una rutina que las carga antes de utilizar la aplicacion de E_Mail.

No resulto.

Agradeceria mucho si alguien me da alguna solucion.

Atte.
Responder Con Cita
  #2  
Antiguo 14-12-2009
Avatar de droguerman
droguerman droguerman is offline
Miembro
 
Registrado: Apr 2005
Ubicación: tierra
Posts: 999
Poder: 13
droguerman Va por buen camino
Aparentemente es un error harto conocido: http://www.google.com.pe/search?ie=U...ad+ssl+library, talvez en tu caso sea un problema de versiones, intenta con el instalador: http://www.slproweb.com/products/Win32OpenSSL.html

otra cosa a intentar es usar Dependency Walker para ver si a los dll no les falta alguna dependencia.

Saludos
__________________
self.free;
Responder Con Cita
  #3  
Antiguo 15-12-2009
camino camino is offline
Miembro
 
Registrado: Feb 2007
Posts: 45
Poder: 0
camino Va por buen camino
Solucion no funciona

Estimado Drogerman
Te agradezco mucho tu colaboracion pero lamentablemente sigo con el mismo problema, es decir la primera vez no reconoce las librerias ssl y a partir de la segunda vez(estando la plicacion abierta) manda los emails sin problema.
Recurri a openssl y baje todos archivos probando con cada uno de ellos.


No Funciona

Gracias
Responder Con Cita
  #4  
Antiguo 20-12-2009
Loviedo Loviedo is offline
Miembro
 
Registrado: Dec 2004
Posts: 214
Poder: 0
Loviedo cantidad desconocida en este momento
He tenido exactamente el mismo problema con Indy9 y Delphi7.
Encontré la solución en la versión de la ssleay32.dll.
Saludos.
Responder Con Cita
  #5  
Antiguo 14-01-2010
Merka Merka is offline
Registrado
 
Registrado: Nov 2006
Posts: 1
Poder: 0
Merka Va por buen camino
Hola, para que funciones bien, pon las .dll en la carpeta gMailSend, y esto en el onCreate.

Código Delphi [-]
procedure TForm1.FormCreate(Sender: TObject); 
begin   
       IdSSLOpenSSLHeaders.Load; 
end;

Luego añade IdSSLOpenSSLHeaders al uses.

un saludo!
Responder Con Cita
  #6  
Antiguo 16-05-2011
JerS JerS is offline
Miembro
 
Registrado: May 2005
Ubicación: Venezuela
Posts: 254
Poder: 12
JerS Va por buen camino
Cita:
Empezado por Merka Ver Mensaje
Hola, para que funciones bien, pon las .dll en la carpeta gMailSend, y esto en el onCreate.

Código Delphi [-]
procedure TForm1.FormCreate(Sender: TObject); 
begin   
       IdSSLOpenSSLHeaders.Load; 
end;

Luego añade IdSSLOpenSSLHeaders al uses.

un saludo!
Excelente Respuesta yo tenia el mismo problema y con esto se a solucionado
__________________
La vida es un simple pero complejo If

J=rS
Responder Con Cita
  #7  
Antiguo 31-05-2011
Avatar de Enan0
Enan0 Enan0 is offline
Miembro
 
Registrado: May 2004
Ubicación: Argentina
Posts: 565
Poder: 13
Enan0 Va por buen camino
Hola Camino! mira te dejo un hilo donde ya se trato el tema.
y dejo un linck a un ejemplo que permite enviar y recibir correos.

saludos.

http://www.clubdelphi.com/foros/showthread.php?t=71834
Responder Con Cita
  #8  
Antiguo 01-10-2012
brandolin brandolin is offline
Miembro
 
Registrado: Jul 2003
Ubicación: Mendoza
Posts: 324
Poder: 14
brandolin Va por buen camino
Perdon por reabri el hilo, pero tengo el mismo problema, estoy trabajando con lazarus + indy10 + linux ubuntu y sale el mensaje de error. Con la configuracion de lazarus + indy10 + windows con las dlls no he tenido problema.
Puse las dll en el mismo directorio del exe y el .load donde se menciona en este hilo y funciona todo ok, el problema surgen el linux. Alguien que pueda darme una mano ???
Gracias.
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Sobre error para enviar email por gmail lduron Varios 8 23-11-2011 00:19:31
enviar un email desde delphi a hotmail o gmail abraham SQL 30 06-08-2007 16:46:20
Enviar correo con SMTP de GMAIL via INDY 10 (idSMTP) lpedrazzi Internet 4 31-12-2006 22:30:26
Problema para enviar email con indy delphi7 cmena Internet 2 13-10-2005 21:58:55
Enviar email con copia y adjunto con indy cmena Internet 4 01-10-2005 01:14:00


La franja horaria es GMT +2. Ahora son las 21:41:55.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi