Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Conexión con bases de datos
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Conexión con bases de datos

 
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo Hace 1 Semana
bucanero bucanero is offline
Miembro
 
Registrado: Nov 2013
Ubicación: Almería, España
Posts: 76
Poder: 5
bucanero Va por buen camino
Error Mysql libmysql.dll found but could not be loaded

Hola buenas tardes,

Utilizo los componentes ZEOSLIB para conectarme a los distintos servidores de MySQL de mis aplicaciones (unos servidores en local y otros en remoto) desde distintos ejecutables con distintas funcionalidades. Hasta el viernes todo funcionaba perfectamente en todos los ordenadores (unos con windows 7 y otros con windows 10), momento en que se apagaron todos los equipos y hoy lunes al iniciar de nuevo todo y de pronto, sin actualizar nada ni cambiar nada, uno de los ordenadores y solo ese en particular con windows 10 ha empezado a no conectar y el error que da es
Client-Library libmysql55.dll, libmysql51.dll, libmysql50.dll, libmariadb.dll, libmysql.dll found but could not be loaded. Check compile-target and library compatibility!
parece ser que si que localiza la DLL de conexion pero no termina de cargarla. En el resto de ordenadores todo funciona perferctamente.

He probado borrandole la DLL libmysql.dll y entonces el error que obtengo es que no encuentra dicha DLL, hasta aqui perfecto, por que es el error esperado y con esto me garantizo que la DLL que esta utilizando esta donde debe de estar. Al volver a copiarle la DLL bien en la carpeta del propio ejecutable (carpeta de red) o bien en la carpeta de windows SYSTEM32 entonces vuelvo a obtener el mismo error inicial.

Para conseguir aislar el error he creado un ejecutable con solamente un TZConnection con la única función de intentar establecer conexión con el servidor local y consigo replicar el error, pero no consigo solucionarlo, pues solo me pasa en este equipo.

Pensando que se pueda tratar ya de algo trastocado en el propio windows, he formateado e instalado una versión limpia de windows en un disco duro nuevo, dentro del mismo equipo, y antes de instalar ningún otro programa o aplicación realizo de nuevo el test de conexión y vuelvo a obtener el mismo error del principio, incluso con todo el windows instalado de nuevo.

Agradezco cualquier sugerencia al respecto pues ya se me acabaron las ideas
Un saludo
Responder Con Cita
 


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Error reading Form. Class TFusionInterop not found. Ignore this error. jo3litro Varios 1 14-08-2015 23:00:08
error field '' not found sonjeux Firebird e Interbase 4 05-07-2015 19:29:31
Problema con inserción de BLOB MySQL desde C++ con libmysql LucasBols MySQL 1 31-05-2012 18:36:19
'DBX Error: No Mapping for Error Code Found' CHECHE81 Conexión con bases de datos 1 09-06-2010 02:11:35
Error: object not found shaktale SQL 0 03-07-2003 16:40:37


La franja horaria es GMT +2. Ahora son las 09:10:03.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi