Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Bases de datos > MySQL
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 16-12-2006
Maibok Maibok is offline
Miembro
 
Registrado: Mar 2005
Posts: 28
Poder: 0
Maibok Va por buen camino
Más de lo mismo ñ, tildes

Hola a todos. Tras una ardua tarea he conseguido hacer funcionar Mysql con Delphi mediante ADO.

He conseguido tabién instalar Zeos, pero tengo dos problemas:

1.- El problema de siempre de ñ y tildes. No sé cómo solucionarlo. SI en mysql pongo conjunto de caracteres latin1 va perfectamente desde la línea de comandos, se ven bien. Pero al abrir delphi y mostrar los registros en tablas me aparecen símbolos raros. Cómo puedo hacer para que se vea bien???. Lo he intentado con UTF8 y sigo teniendo problemas. Por favor, agradecería pasito a pasito la explicación, muchas gracias.

2.- Al utilizar los ZEOS me da error en las librerías libmysqld50.dll y libmysqld.dll. La primera la trae el paquete que me bajé, pero la segunda no, de dónde la puedo bajar???. Y una vez que tenga las dos. En qué directorio tengo que copiarlas examentamente???.

Gracias por la atención. Espero que me puedan ayudar, es MUY IMPORTANTE.


Saludos
Responder Con Cita
  #2  
Antiguo 16-12-2006
Avatar de AzidRain
[AzidRain] AzidRain is offline
Miembro Premium
 
Registrado: Sep 2005
Ubicación: Córdoba, Veracruz, México
Posts: 2.914
Poder: 15
AzidRain Va por buen camino
Cambia la propiedad CharSet (que esta dentro de font) de tu Grid o componente que muestre los datos para que quede en OEM_CHARSET. Con eso basta...

Imagen




Alguien me explica que pasa con las imagenes que no se pueden poner??
__________________
AKA "El animalito" ||Cordobés a mucha honra||
Responder Con Cita
  #3  
Antiguo 18-12-2006
Maibok Maibok is offline
Miembro
 
Registrado: Mar 2005
Posts: 28
Poder: 0
Maibok Va por buen camino
Muchas gracias, ya lo he visto.

Sólo una cosa más. ALguien me podría responder a la segunda cuestión????.

Gracias otra vez
Responder Con Cita
  #4  
Antiguo 18-12-2006
Avatar de dec
dec dec is offline
Moderador
 
Registrado: Dec 2004
Ubicación: Alcobendas, Madrid, España
Posts: 12.617
Poder: 27
dec Va camino a la famadec Va camino a la fama
Hola,

Esa "DLL" parece contener el Servidor de MySQL "embebido". Descarga la versión de MySQL y echa un vistazo en la carpeta "Embedded" conque contarás tras su instalación/copia. Ahí tienes la "DLL" que andas buscando. A lo menos hablando de la versión 4.x de MySQL. Ignoro si en la versión 5.x es así también.
__________________
David Esperalta
www.davidesperalta.com
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Porque no me recibe ni tíldes ni ñ? fidel Firebird e Interbase 13 12-04-2007 21:13:16
tildes caprichosos elcigarra PHP 7 30-09-2006 23:06:59
problemas con las tildes, la ñ en el servidor web FEDORA cahosoft Linux 2 12-07-2006 09:53:22
problema con eñes y tildes jarto MySQL 1 28-04-2005 15:01:47
UPPER, UpperCase con eñes, tildes ... Tomás Firebird e Interbase 3 15-01-2004 18:24:24


La franja horaria es GMT +2. Ahora son las 01:55:12.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi