Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > OOP
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos


 
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo Hace 1 Semana
ramonigimenez ramonigimenez is offline
Miembro
 
Registrado: ago 2015
Posts: 10
Poder: 0
ramonigimenez Va por buen camino
Problemas con constructor de clase

Hola amigos,

Soy nuevo con delphi y estoy intentando amigarme con el lenguaje.
Pero me encontre con un problema que no puedo resolver por mi falta de experiencia.
Defini una clase (Espero que este bien), pero cuando compilo me da un error que describo debajo

Código:
//DEFINIECION DE CLASE
TFuente=class(tObject)
   private
    fColorFondo: TColor;
    fFuente: TFont;
  public
     Constructor Create;
    destructor Destroy; override;
     Procedure SaveToStream(Const aDest:Tstream);
    Procedure LoadFromStream(Const aSource:TStream);
    procedure Assign(const aSource:TFuente);
    property Fuente:TFont read fFuente write fFuente;
    property ColorFondo:TColor read fColorFondo write fColorFondo;
    end;


 //ERROR QUE DEVUELVE
[DCC Error] untClasses.pas(5):[DCC Error] E2065 Unsatisfied forward or external declaration: 'TFuente.Create'
En la sección use utilizo
Código:
uses Classes, SysUtils, Graphics, Controls,Forms, Jpeg, gifimage,Windows,
System2
Supuse que el error me lo daba porque no llame a la clase System, pero si la agrego a use
me da este error
Código:
[DCC Error] untClasses.pas(5): E2004 Identifier redeclared: 'System'
Espero puedan ayudarme, muchas gracias
Responder Con Cita
 


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problemas con ¿ADO?: Clase no registrada sitrico Conexión con bases de datos 3 19-02-2014 18:49:04
Problemas con el constructor de una clase Ledian_Fdez C++ Builder 1 05-04-2010 13:59:23
Problemas al crear mi primera clase Kandorf OOP 6 04-12-2009 02:00:23
Implementar el constructor de una clase Alcolea OOP 2 14-06-2006 07:39:05
Problemas con la clase TQRDBRichText en Delphi 7 osmel Impresión 0 07-12-2005 22:18:37


La franja horaria es GMT +2. Ahora son las 13:00:41.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi