Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Gráficos
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 27-11-2003
omy omy is offline
Miembro
 
Registrado: Aug 2003
Ubicación: Acapulco gro.
Posts: 100
Poder: 15
omy Va por buen camino
como cargo una imagen

como cargo una imagen que guarde en un campo ole de access la imagen es jpg. requiero ponerla en un objeto image

Espero me puedan ayudar, .....
__________________
omar velazquez
Responder Con Cita
  #2  
Antiguo 28-11-2003
Descendents Descendents is offline
Miembro
 
Registrado: May 2003
Ubicación: Barcelona
Posts: 396
Poder: 16
Descendents Va por buen camino
en la propiedad picture, en un image.

En un db image, si lo asignas al datasource y al campo y listo.
Me parece que estaras limitado a que sean bmp.

Jpg y gif no creo que te funcionen con dicho componetne
Un saludo
Responder Con Cita
  #3  
Antiguo 28-11-2003
madriles madriles is offline
Miembro
 
Registrado: May 2003
Ubicación: madrid
Posts: 93
Poder: 16
madriles Va por buen camino
hola
normalmente algunos problemas, por obvios, los pasamos por alto. He tenido, en ocasiones, problemas con jpg, y pasarme horas viendo que pasaba y al final...
se me olvido poner Jpeg en el uses ( exceso de confianza ), a ver si es tu caso
Responder Con Cita
  #4  
Antiguo 28-11-2003
omy omy is offline
Miembro
 
Registrado: Aug 2003
Ubicación: Acapulco gro.
Posts: 100
Poder: 15
omy Va por buen camino
ok tengo una base de datos de alumnos , pero el campo foto es de tipo ole, para poder sacar la foto y pasarla hay que hacerlo de la siguiente manera, este codigo lo modifique, pero no pude hacerlo funcionar..

begin
//T := TBlobField.Create(SQLDataSet1);
//T.FieldName := 'Images';
AdoTable1Picture := tblobfield.Create(DataSource6);
// AdoTable1Picture.FieldName := 'foto';
// AdoTable1Picture.ReadOnly :=False;
//AdoTable1Picture.
bS := TADOBlobStream.Create(AdoTable1Picture,bmRead);
try
bS.Seek(JpegStartsInBlob(AdoTable1Picture),
soFromBeginning);
Pic:=TJpegImage.Create;
try
Pic.LoadFromStream(bS);
ADOImage.Picture.Graphic:=Pic;
finally
Pic.Free;
end;
finally
bS.Free
end;



bueno alguien no recuerdo quien me ayudo aqui en el foro, pero no he podido hacer que funcione.....
__________________
omar velazquez
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro


La franja horaria es GMT +2. Ahora son las 14:15:03.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi