Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Bases de datos > PostgreSQL
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 16-02-2008
mbernal mbernal is offline
Registrado
 
Registrado: Feb 2008
Posts: 1
Poder: 0
mbernal Va por buen camino
POSTGRESQL y ADO

Hola foro, estoy usando ADO para conectarme a postgresql, todo bien... hasta que ejecuto un INSERT, DELETE o UPDATE, me manda el siguiente mensaje: "No hay columnas definidas en el conjunto de filas", sin embargo la instrucción SQL se realiza bien. Alguna idea de evitar que aparezca dicho mensaje?

Gracias
Responder Con Cita
  #2  
Antiguo 17-02-2008
keyboy keyboy is offline
Miembro
 
Registrado: Oct 2004
Posts: 367
Poder: 15
keyboy Va por buen camino
¿Cómo estás realizando la consulta?

Suena a que usas ADOQuery.Open o ADOQuery.Active := true. De ser así, usa ADOQuery.Execute. Open es sólo para consultas que devuelven registros (SELECT).

Bye
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
PostgreSQL 8.3 RC2 Disponible poliburro Noticias 0 22-01-2008 18:08:30
PHP y postgresql halizia PHP 3 14-03-2007 14:54:58
postgreSQL 8.0 + eñe gustavoh Conexión con bases de datos 0 13-02-2006 02:48:49
Firebird - PostgreSQL wod Conexión con bases de datos 8 18-11-2005 21:21:50


La franja horaria es GMT +2. Ahora son las 20:57:10.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi