Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Varios
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

 
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 16-05-2017
davidrgh davidrgh is offline
Miembro
 
Registrado: ene 2012
Posts: 11
Poder: 0
davidrgh Va por buen camino
Problema: Delphi no encuentra ningún certificado electrónico para acceder a un WS

Buenos días

Estoy programando un módulo en Delphi 2010 para que una empresa pueda comunicarse con la AEAT e informar de sus registros de IVA mediante el sistema nuevo de Suministro Inmediato de Información del IVA (SII) que entrará en vigor en Julio.

Para ello he utilizado el WSDL Importer para generar en Delphi los objetos necesarios para componer el mensaje y enviarlo. El WSDL en cuestión (por ejemplo) es: En Delphi relleno todos los datos necesarios en el objeto que me crea. Después, obtengo el objeto SOAP (método GetsiiSOAP) y llamo a la función SuministroLRFacturasEmitidas pasándole el objeto con los datos. Llegados a este punto, automáticamente me muestra una lista de los certificados electrónicos que tengo instalado para elegir el que quiero usar (en mi ordenador solo tengo el mío personal emitido por la FNMT). Accede al servicio y envía sin problemas el mensaje.

El problema viene cuando lo probamos a ejecutar en el cliente. En el ordenador del cliente hay instalados varios certificados de empresa (aunque también hemos hecho la prueba instalando el mismo certificado que hemos usado para testearlo en mi ordenador). Sin embargo, cuando llega a la parte donde debería mostrar la lista, salta el siguiente error:



Hemos probado en varios ordenadores del cliente y en todos da lo mismo. En los ordenadores de mi empresa (hay 3) funciona correctamente. En el cliente pueden acceder al portal de pruebas con sus certificados sin mayor problema, pero no le carga la lista cuando accede al servicio desde nuestra aplicación.

¿Alguna pista de qué puede estar ocurriendo?

Muchas gracias

Última edición por Casimiro Notevi fecha: 16-05-2017 a las 13:16:32.
Responder Con Cita
 


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Componente para Pago Electrónico en Delphi 7 lgarcia Varios 2 25-02-2015 14:30:01
Gran Problema: Delphi no encuentra un archivo. Holderhek Varios 2 03-02-2005 21:26:42


La franja horaria es GMT +2. Ahora son las 22:15:02.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi